From: Junio C Hamano Date: Tue, 22 Sep 2026 19:41:56 GMT Subject: Re: [PATCH v5 1/3] t4001: modernize Message-ID: In-Reply-To: <20260922143119.3313620-2-markchucarroll@fastmail.com> "Mark C. Chu-Carroll" writes: > Old tests were written in a different style than modern > ones; for better readability and test error messages, > update t4001 to the modern style. > > * run everything inside of a test_expect_success block. > * write title line on the same line as test_expect_success, > end that line with a single quote that opens the body of the test, > and end the test with a single quote that closes the body. > * write expected output of a test to a file named "expect", > and actual output to a file named "actual". > * write here-docs using "<<-" syntax, so that they're indented > uniformly with the rest of the test. > * make test names more clearly reflect the functionality that > they test. > > Signed-off-by: Mark C. Chu-Carroll > --- > t/t4001-diff-rename.sh | 91 +++++++++++++++++----------------------- > t/t4009-diff-rename-4.sh | 54 ++++++++++++------------ > 2 files changed, 66 insertions(+), 79 deletions(-) Rebase glitch? The claim above is that this is about updating t4001 but it seems that a half of t4009 updates are mixed in.