From: Junio C Hamano Date: Fri, 08 Jan 2016 22:07:00 GMT Subject: Re: [PATCH v2 1/4] Refactor skipping DOS drive prefixes Message-ID: In-Reply-To: Eric Sunshine writes: > With this change, code such as: > > for (i = has_dos_drive_prefix(src); i > 0; i--) > ... > > in path.c reads a bit oddly. Renaming the function might help. For instance: > > for (i = dos_drive_prefix_len(src); i > 0; i--) > ... Renaming may be unnecessary churn, but I do not think we mind an additional synonym, e.g. #define has_dos_drive_prefix(x) dos_drive_prefix_len(x) if some people prefer.