From: Junio C Hamano Date: Fri, 27 Oct 2017 01:20:24 GMT Subject: Re: [PATCH] dir: allow exclusions from blob in addition to file Message-ID: In-Reply-To: <20171026180222.39421-2-git@jeffhostetler.com> Jeff Hostetler writes: > From: Jeff Hostetler > > Refactor add_excludes() to separate the reading of the > exclude file into a buffer and the parsing of the buffer > into exclude_list items. > > Add add_excludes_from_blob_to_list() to allow an exclude > file be specified with an OID without assuming a local > worktree or index exists. > > Refactor read_skip_worktree_file_from_index() and add > do_read_blob() to eliminate duplication of preliminary > processing of blob contents. > > Signed-off-by: Jeff Hostetler > --- Yeah, with a separate do_read_blob() helper, this one looks a lot easier to follow, at least to me---as the author, you might find the earlier one just as easy, I suspect, though ;-) Thanks. Will queue.