From: Junio C Hamano Date: Tue, 27 Feb 2024 18:10:12 GMT Subject: Re: [PATCH v3 04/11] Prepare `paint_down_to_common()` for handling shallow commits Message-ID: In-Reply-To: Junio C Hamano writes: > I suspect that what made it harder to follow in the original > construct is that we called the behaviour "incorrect" upfront and > then come back with "that incorrectness is what we want". Oh, I forgot to say that lack of ": " on the title of the earlier parts of the series were a bit uncomfortable to read.