From: Junio C Hamano Date: Tue, 02 May 2017 01:36:31 GMT Subject: Re: [PATCH 0/5] Start of a journey: drop NO_THE_INDEX_COMPATIBILITY_MACROS Message-ID: In-Reply-To: <20170501190719.10669-1-sbeller@google.com> Stefan Beller writes: > This applies to origin/master. > > For better readability and understandability for newcomers it is a good idea > to not offer 2 APIs doing the same thing with on being the #define of the other. > > In the long run we may want to drop the macros guarded by > NO_THE_INDEX_COMPATIBILITY_MACROS. This converts a couple of them. Why? Why should we keep typing &the_index, when most of the time we are given _the_ index and working on it?