From: Junio C Hamano Date: Fri, 27 Dec 2019 22:21:17 GMT Subject: Re: [PATCH v2 1/1] gpg-interface: add minTrustLevel as a configuration option Message-ID: In-Reply-To: <87r20pkhir.hji@dyntopia.com> Hans Jerry Illikainen writes: >> I wonder if the code becomes less misleading if we either (1) >> renamed 'next' to a name that hints more strongly that it is not the >> 'next' line but the end of the current token we are interested in, >> or (2) get rid of the pointer and instead counted size of the >> current token we are interested in, or perhaps both? > > Yeah the name 'next' does seem a bit counter-intuitive when used in > relation to 'line'. Looking through the function it seems that both (1) > and (2) would work. Thanks for thinking the code a bit more than necessary for the purpose of this topic. Let's leave such a clean-up outside the scope of this topic, but perhaps a #leftoverbits marker may help us remember it as something we could do when we have nothing else better to do ;-)