From: Junio C Hamano Date: Wed, 01 Jul 2020 19:51:15 GMT Subject: Re: [PATCH v5] Enable auto-merge for meld to follow the vim-diff beharior Message-ID: In-Reply-To: <20200701141755.GB1966@danh.dev> Đoàn Trần Công Danh writes: >> +mergetool.meld.hasAutoMerge:: >> + Older versions of `meld` do not support the `--auto-merge` option. >> + Setting `mergetool.meld.hasOutput` to `true` tells Git to > > s/hasOutput/hasAutoMerge/ > > Bikeshed opinion: I don't know if hasAutoMerge is a good name :) I do not think "has" is a good choice for this one, even though hasOutput may very well be a good one for "output". As the paragraph describes (below), this lets the user "avoid" using "--auto-merge", even if the version of "meld" the user has does have the automerge capability. So perhaps say "mergetool.meld.useAutoMerge"; that will let the users express exactly their wish---don't use it (false), do forcibly try to use it (true), or use it when able (auto).