From: Junio C Hamano Date: Wed, 15 Oct 2025 14:45:48 GMT Subject: Re: [PATCH v3 0/3] replay: make atomic ref updates the default Message-ID: In-Reply-To: Siddharth Asthana writes: > Option 1: `replay.refAction` ↔ `--ref-action=(update|print)` > Option 2: `replay.updateRefs` ↔ `--update-refs=(yes|print)` > > I am leaning toward Option 1 because: > - "ref-action" clearly conveys "what action to take on refs" > - The config name `replay.refAction` directly mirrors the option > - It's more obvious what the relationship is > > What do you think? I am happy to go with either approach or a > different naming scheme if you have a preference. My preference is the refAction, simply because updateRefs sounds to me like it is asking "do you want me to update refs? Yes or no?". But perhaps there were those who supported updateRefs during the past reviews I wasn't looking at, so I'd like to hear if my thinking is missing something that were taken into consideration to come up with that name. Thanks.