From: Junio C Hamano Date: Fri, 28 Aug 2026 15:41:24 GMT Subject: Re: [PATCH v3 1/5] commit: clarify FROM_REBASE_PICK and is_from_rebase() names Message-ID: In-Reply-To: <7e198a20fa47f0d5b2c50ffc7046bdfc792b62af.1787903085.git.gitgitgadget@gmail.com> "Elijah Newren via GitGitGadget" writes: > From: Elijah Newren > > Commit 430b75f7209c (commit: give correct advice for empty commit during > a rebase, 2019-12-06) introduced a FROM_REBASE_PICK enum value and an > is_from_rebase() function. Those names failed to convey that they were > specifically about hitting a commit that becomes empty when rebasing. > Clarify their names now. Becomes empty is different from picking an empty commit, right. I am not sure if "is_from_rebase_empty()" conveys the difference and more importantly, I am afraid it hints the latter. I have a feeling that EMPTY_REBASE (instead of REBASE_EMPTY) may match what we want to express slightly better, but not by a large margin to make a difference. Perhaps Phillip has a better idea? > While at it, change `whence == FROM_REBASE_EMPTY` to use > `is_from_rebase_empty(whence)`. Very much appreciated.