From: Junio C Hamano Date: Mon, 03 Mar 2014 18:49:27 GMT Subject: Re: [PATCH v2] branch.c: change install_branch_config() to use skip_prefix() Message-ID: In-Reply-To: Eric Sunshine writes: >> diff --git a/branch.c b/branch.c >> index 723a36b..ca4e824 100644 >> --- a/branch.c >> +++ b/branch.c >> @@ -50,7 +50,7 @@ static int should_setup_rebase(const char *origin) >> void install_branch_config(int flag, const char *local, const char *origin, const char *remote) >> { >> const char *shortname = remote + 11; >> - int remote_is_branch = starts_with(remote, "refs/heads/"); >> + int remote_is_branch = (NULL != skip_prefix(remote ,"refs/heads/")); > > This actually makes the code more difficult to read and understand. > There's a more fundamental reason to use skip_prefix() here. See if > you can figure it out. (Hint: shortname) I've already queued 0630aa49 (branch: use skip_prefix() in install_branch_config(), 2014-02-28) on this topic, by the way.