From: Junio C Hamano Date: Wed, 12 Mar 2014 19:02:10 GMT Subject: Re: [PATCH][GSoC] parse-options: Add OPT_SET_INT_NONEG. Message-ID: In-Reply-To: Yuxuan Shui writes: > On Thu, Mar 13, 2014 at 2:30 AM, Junio C Hamano wrote: >> Duy Nguyen writes: >> >>> By convention, no full stop in the subject line. The subject should >>> summarize your changes and "add ..NONEG" is just one part of it. The >>> other is "convert to use ...NONEG". So I suggest "parse-options: >>> convert to use new macro OPT_SET_INT_NONEG()" or something like that. >>> >>> You should also explain in the message body (before Signed-off-by:) >>> why this is a good thing to do. My guess is better readability and >>> harder to make mistakes in the future when you have to declare new >>> options with noneg. >> >> As I said elsewhere, I am not sure if doubling the number of >> OPT_ macros as your micro suggestion proposes is the right >> solution to the problem. >> >> What are we trying to solve? > > OK, I'll switch to another micro project. That is fine, but note that it was not an objection but was a pure question. I was asking you to explain why this is a good change.