From: Junio C Hamano Date: Mon, 04 Jan 2016 18:34:36 GMT Subject: Re: [PATCH] commit: ensure correct permissions of the commit message Message-ID: In-Reply-To: Johannes Schindelin writes: >> I do not know fcreate_or_truncate() is a good name, though. > > So what would be a good name? Have been thinking about it, but I did not come up with anything. I just know fcreate_or_truncate() is not a good name for multiple reasons I already explained X-<. sane_fopen_for_writing() perhaps?