From: Junio C Hamano Date: Fri, 12 Mar 2021 23:45:36 GMT Subject: Re: remote..merge missing from the git-config man page? Message-ID: In-Reply-To: <87a6rd2tp8.fsf@igel.home> Andreas Schwab writes: > On Mär 08 2021, Taylor Blau wrote: > >> On Mon, Mar 08, 2021 at 09:57:56PM +0100, Andreas Schwab wrote: >>> The configured upstream is the value of branch..merge, isn't it? >>> That would be the name of a remote, not the name of a branch. >> >> Right; the '' in 'branch..merge' is your local name for a >> branch, but the value of that configuration is the remote's name. > > Sorry, I was misreading branch..merge as branch..remote. > Now it makes all sense to me. OK, so do we have a version that is good to go? Thanks. -- >8 -- From: Taylor Blau Date: Mon, 8 Mar 2021 13:43:47 -0500 Subject: [PATCH] Documentation/git-push.txt: correct configuration typo In the EXAMPLES section, git-push(1) says that 'git push origin' pushes the current branch to the value of the 'remote.origin.merge' configuration. This wording (which dates back to b2ed944af7 (push: switch default from "matching" to "simple", 2013-01-04)) is incorrect. There is no such configuration as 'remote..merge'. This likely was originally intended to read "branch..merge" instead. Indeed, when 'push.default' is 'simple' (which is the default value, and is applicable in this scenario per "without additional configuration"), setup_push_upstream() dies if the branch's local name does not match 'branch..merge'. Correct this long-standing typo to resolve some recent confusion on the intended behavior of this example. Reported-by: Adam Sharafeddine Reported-by: Fabien Terrani Signed-off-by: Taylor Blau Signed-off-by: Junio C Hamano --- Notes (amlog): Message-Id: Documentation/git-push.txt | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/Documentation/git-push.txt b/Documentation/git-push.txt index ab103c82cf..a953c7c387 100644 --- a/Documentation/git-push.txt +++ b/Documentation/git-push.txt @@ -600,7 +600,7 @@ EXAMPLES `git push origin`:: Without additional configuration, pushes the current branch to - the configured upstream (`remote.origin.merge` configuration + the configured upstream (`branch..merge` configuration variable) if it has the same name as the current branch, and errors out without pushing otherwise. + -- 2.31.0-rc2-171-g89112de4ba