From: Junio C Hamano Date: Wed, 19 Mar 2014 17:22:48 GMT Subject: Re: [PATCH 1/3][GSOC] diff: rename read_directory() to get_directory_list() Message-ID: In-Reply-To: Junio C Hamano writes: > Hiroyuki Sano writes: > >> Including "dir.h" in "diff-no-index.c", it causes a compile error, because >> the same name function read_directory() is declared globally in "dir.h". >> >> This change is to avoid conflicts as above. >> >> Signed-off-by: Hiroyuki Sano >> --- >> diff-no-index.c | 6 +++--- >> 1 file changed, 3 insertions(+), 3 deletions(-) >> >> diff --git a/diff-no-index.c b/diff-no-index.c >> index 8e10bff..1ed5c9d 100644 >> --- a/diff-no-index.c >> +++ b/diff-no-index.c >> @@ -16,7 +16,7 @@ >> #include "builtin.h" >> #include "string-list.h" >> >> -static int read_directory(const char *path, struct string_list *list) >> +static int get_directory_list(const char *path, struct string_list *list) > > Renaming is a good idea but the new name sounds like you are > grabbing the names of directories, ignoring all the files, no? I am tempted to suggest, because this is an internal implementation detail only visible to this narrow corner of the system, calling this just static int ls(const char *path, struct string_list *result) ;-)