From: Junio C Hamano Date: Mon, 13 Nov 2017 04:24:25 GMT Subject: Re: [PATCH v3 0/4] Hash abstraction Message-ID: In-Reply-To: <20171112212854.791179-1-sandals@crustytoothpaste.net> "brian m. carlson" writes: > This is a series proposing a basic abstraction for hash functions. > > The full description of the series can be found here: > https://public-inbox.org/git/20171028181239.59458-1-sandals@crustytoothpaste.net/ > > At the bottom of this message is the output of git tbdiff between v2 and > v3. > > Changes from v2: > * Remove inline. > * Add dummy functions that call die for unknown hash implementation. > * Move structure definitions to hash.h and include git-compat-util.h in > hash.h. > * Rename current_hash to the_hash_algo. > * Use repo_set_hash_algo everywhere we set the hash algorithm for a > struct repository. Change for all of the above in this series looked sensible to me. Thank, will queue.