From: Junio C Hamano Date: Fri, 17 Nov 2017 01:12:14 GMT Subject: Re: [PATCH 1/5] connect: split git:// setup into a separate function Message-ID: In-Reply-To: <20171115202516.hduhzsgeoff5a22b@aiede.mtv.corp.google.com> Jonathan Nieder writes: >> Which means the defaulting of git_connect::conn to &no_fork is now >> unneeded. One of the things that made the original cascade a bit >> harder to follow than necessary, aside from the physical length of >> the PROTO_GIT part, was that the case where conn remains to point at >> no_fork looked very special and it was buried in that long PROTO_GIT >> part. > > Good idea. Here's what I'll include in the reroll. Sounds good.