From: Junio C Hamano Date: Wed, 16 Sep 2020 22:52:16 GMT Subject: Re: [PATCH] config: option transfer.ipversion to set transport protocol version for network fetches Message-ID: In-Reply-To: Junio C Hamano writes: > Jeff King writes: > >> Adding a command-line option for "all" is a good idea, but will probably >> mean needing to add the "unset" sentinel value I mentioned in the other >> email. > > Sorry, I do not quite follow. I thought that assigning the > (misnamed --- see other mail) ALL to the "family" variable would be > sufficient? > > enum transport_family { > TRANSPORT_FAMILY_ALL = 0, > TRANSPORT_FAMILY_IPV4, > TRANSPORT_FAMILY_IPV6 > }; Ah, I see. We want a way to tell "nobody has set it from the command line or the config" and "we were explicitly told to accept any" apart. But wouldn't the usual "read config first and then override from the command line" handle that without "not yet set" value? I thought we by default accept any.