From: Junio C Hamano Date: Fri, 20 Dec 2013 21:31:37 GMT Subject: Re: [PATCH 02/12] Convert starts_with() to skip_prefix() for option parsing Message-ID: In-Reply-To: <20131220070449.GA29717@sigill.intra.peff.net> Jeff King writes: > /* here we care if we saw the prefix, as above */ > if (parse_prefix(foo, prefix, &the_rest)) > ... > > /* > * and here we do not care, and just want to optionally strip the > * prefix, and take the full value otherwise; we just have to ignore > * the return value in this case. > */ > parse_prefix(foo, prefix, &foo); Sounds fine. I recall earlier somebody wanting to have a good name for this thing, and I think foo_gently is *not* it (the name is about adding a variant that does not die outright to foo that checks and dies if condition is not right). starts_with(foo, prefix); strip_prefix(foo, prefix, &foo); perhaps?