From: Junio C Hamano Date: Fri, 15 Apr 2016 22:12:36 GMT Subject: Re: [PATCH v2 17/21] bisect: rename count_distance() to compute_weight() Message-ID: In-Reply-To: <1460294354-7031-18-git-send-email-s-beyer@gmx.net> Stephan Beyer writes: > Let us use the term "weight" for the number of ancestors > of each commit, and "distance" for the number > min{weight, #commits - weight}. (Bisect finds the commit > with maximum distance.) > > In these terms, "count_distance()" is the wrong name of > the function. So it is renamed to "compute_weight()", > and it also directly sets the computed weight. > > Signed-off-by: Stephan Beyer > --- > bisect.c | 11 ++++++----- > 1 file changed, 6 insertions(+), 5 deletions(-) Makes sense. We can think of the "distance" the distance from the periphery of the graph we are looking at, and "bisection" is to find a point close to the center of the graph.