From: Junio C Hamano Date: Tue, 01 Sep 2020 15:58:54 GMT Subject: Re: [PATCH] xrealloc: do not reuse pointer freed by zero-length realloc() Message-ID: In-Reply-To: <20200901135105.GA3284077@coredump.intra.peff.net> Jeff King writes: > If we do handle it up-front, then I think we'd actually want: > > if (!size) { > free(ptr); > return xmalloc(0); > } > > (i.e., to never return NULL for consistency with xmalloc() and > xcalloc()). Makes sense. I suspect that this is optimizing for a wrong case, but in practice that should not matter. Not having to worry about a request to resize to 0-byte in the remainder of the function is actually a plus for readability, I would say. >> > @@ -120,7 +120,7 @@ void *xrealloc(void *ptr, size_t size) >> > memory_limit_check(size, 0); >> > ret = realloc(ptr, size); >> > if (!ret && !size) >> > - ret = realloc(ptr, 1); >> > + ret = realloc(ret, 1); >> >> I appreciate all the additional context for such a small change. > > Somebody's got to complete with you for ratio of commit message to diff > lines. :) > > -Peff