From: Junio C Hamano Date: Tue, 14 Oct 2025 20:16:12 GMT Subject: Re: [PATCH 2/5] setup: rename `die_upon_assumed_unsafe_repo()` to align with check Message-ID: In-Reply-To: <20251013094152.23597-3-git@lohmann.sh> Michael Lohmann writes: > This function dies if the repo in question is deemed to be unsafe and > the ownership is only part of the verification. In addition it already > checks for "safe.directory" config, making the name > `ensure_valid_ownership()` not expressive. > When additional options to check if a repository is considered to be > safe are added, this name is more indicative of the content. The new name chosen in the previous step makes perfect sense, and the previous step sounds like a good thing to do. Likewise, I can understand the reason why we want to rename this helper here, as the reason why we die no longer is based solely on ownership. But why "assumed unsafe", instead of just "die_upon_unsafe_repo()"?