From: Junio C Hamano Date: Fri, 15 Nov 2019 05:26:31 GMT Subject: Re: [PATCH 21/27] t: define test_grep_return_success() Message-ID: In-Reply-To: <3f79d23b40c0586d0351f4d721097be4f7ba26b8.1573779465.git.liu.denton@gmail.com> Denton Liu writes: > +# Calls grep but returns zero even if no matching lines are found. > +test_grep_return_success () { > + grep "$@" || : > +} It makes sense to have a helper like this, but the name is quite a mouthful. I wonder if we can call it with a shorter name, e.g. "test_filter" or something.