From: Matthieu Moy Date: Mon, 17 Mar 2014 07:23:40 GMT Subject: Re: [PATCH] branch.c: simplify chain of if statements Message-ID: In-Reply-To: <1395004962-18200-1-git-send-email-dragos.foianu@gmail.com> Dragos Foianu writes: > + const char *verbose_prints[4] = { > + "Branch %s set up to track remote branch %s from %s%s", > + "Branch %s set up to track local branch %s%s", > + "Branch %s set up to track remote ref %s%s", > + "Branch %s set up to track local ref %s%s" > + }; > + char *verbose_rebasing = rebasing ? " by rebasing." : "."; > + This seems to be a "lego construct" that makes translation harder: are you sure that the "by rebasing" will be at the end of the sentence in any languages? Also, this lacks the _() on verbose_rebasing, which isn't translatable anymore after your patch. I personnally think that the table-driven approach is wrong here, it makes the code shorter but much harder to read. -- Matthieu Moy http://www-verimag.imag.fr/~moy/