From: Matthieu Moy Date: Thu, 29 Jul 2010 07:19:16 GMT Subject: Re: [PATCH 1/4 v2] Allow detached form (e.g. "-S foo" instead of "-Sfoo") for diff options Message-ID: In-Reply-To: <20100729020031.GI29156@dert.cs.uchicago.edu> Jonathan Nieder writes: >> + } && >> + test "$actual" = "$actual_detached" || { >> + echo Oops. Detached form broken >> + echo "Actual_detached: $actual_detached" >> } > > You left out the crucial "false"! :) Oups, right. > Below is an add-on patch to use a more readable style. I was mimicking the style right above, but that makes sense to clean-up while we're there, yes. I'll squash your change in the next serie. -- Matthieu Moy http://www-verimag.imag.fr/~moy/