From: Matthieu Moy Date: Thu, 07 Feb 2013 07:08:59 GMT Subject: Re: [PATCH] git-send-email: add ~/.authinfo parsing Message-ID: In-Reply-To: <8738x9ghpu.fsf@lifelogs.com> Ted Zlatanov writes: > Logically they are different steps (query and response), even though the > data protocol is the same. But it's really not a big deal, I know what > it means either way. Yes, but if you rename write() to query(), then on the helper side, you'll have to call query() to send the response, and response() to read the query. Much worse than keeping read/write. Plus, read/write has already been used for a while in the C API, so I'd rather keep the same names for the Perl equivalent. -- Matthieu Moy http://www-verimag.imag.fr/~moy/