From: Matthieu Moy Date: Mon, 08 Jun 2015 14:42:11 GMT Subject: Re: [WIP/PATCH v5 03/10] for-each-ref: rename 'refinfo' to 'ref_array_item' Message-ID: In-Reply-To: <1433574581-23980-3-git-send-email-karthik.188@gmail.com> Karthik Nayak writes: > Make 'symref' a non const char pointer, so that the compiler doesn't > throw an error when we try to free the memory allocated to it. Casting to non-cost when calling free() is a common pattern. I think it would make more sense to cast at free() time and keep the member const. -- Matthieu Moy http://www-verimag.imag.fr/~moy/