From: Jakub Narebski Date: Fri, 03 Jun 2011 08:33:21 GMT Subject: Re: [PATCHv4 1/4] Refactor for_each_ref variants to use for_each_ref_in and avoid magic numbers Message-ID: In-Reply-To: <1306887870-3875-1-git-send-email-jamey@minilop.net> This patch series would surely benefit from a cover letter... Jamey Sharp writes: > From: Josh Triplett > > Several variants of the for_each_ref functions call do_for_each_ref with > both a fixed string prefix and the hardcoded length of that prefix. > Furthermore, for_each_ref and for_each_ref_submodule passed "refs/" but > a length of 0, which caused do_for_each_ref to ignore the "refs/". [...] -- Jakub Narebski Poland ShadeHawk on #git