From: Avery Pennarun Date: Fri, 07 May 2010 19:36:45 GMT Subject: Re: [PATCH/RFC 0/3] Per-repository end-of-line normalization Message-ID: In-Reply-To: On Fri, May 7, 2010 at 3:31 PM, Nicolas Pitre wrote: > On Fri, 7 May 2010, Linus Torvalds wrote: >> Btw, another option might be to start searching ".gitconfig", but only >> allow a certain "safe subset" of config options in that. Things that can >> really be about the project itself, and not per-user or per-repository. >> >> And parse it before ~/.gitconfig and .git/config, so that people can >> always override it. >> >> I dunno. Looking at the config options, there really aren't a lot of them >> that make sense on a project scale. There's a few, though. Things like >> >>       core.autocrlf >>       i18n.commitEnconfig >> >> and possibly others.. > > Given that only a subset of gitconfig could make sense to have > distributed, I think the file should be named .gitparams to make the > distinction clear. Since the options it *does* have are exactly the same as .git/config, however, naming it .gitconfig makes sense. I'd say just print a warning when reading options that are going to be ignored for security reasons (or because they're not known at all, or whatever). Avery