From: Michael Olson Date: Wed, 21 Apr 2010 17:02:50 GMT Subject: Re: [PATCH/RFC 0/2] git-svn: Allow certain refs to be ignored Message-ID: In-Reply-To: <20100421165451.GA14004@dcvr.yhbt.net> On Wed, Apr 21, 2010 at 9:54 AM, Eric Wong wrote: > Michael Olson wrote: >> ^refs/remotes/((tags/)?old/myorg|old/bad_branch|old/unlabeled[^/]*|tags/(old/bad_tag|releases/another_tag))$ > > I wonder if both would be better as a series of globs would be > easier to read (maybe more verbose to write): > >        ignoreRefs = refs/remotes/tags/old/myorg >        ignoreRefs = refs/remotes/old/myorg >        ignoreRefs = refs/remotes/old/unlabeled/* That does look cleaner, and kind of reminiscent of .gitignore. -- Michael Olson | http://mwolson.org/