From: Ralf Ebert Date: Mon, 09 Aug 2010 23:34:41 GMT Subject: Re: [PATCH] More readable 'Not a git repository' messages Message-ID: In-Reply-To: <20100809230132.GG4429@burratino> Hi Jonathan, > I hope not, since then the returned cwd value would be useless > for restoring the original cwd later. yes, right, I misread the code, thanks for taking the time to correct me. My C knowledge is dated to say least and being succumbed by all the syntax sugar of dynamic languages, I misread if (chdir("..")) { ... } as "if changing the directory worked ok" :) > Shameless plug: you may find the version in commit 98937be (i.e. > branch jn/maint-setup-fix in pu) more readable. :) I do, I guess it makes sense to rework the patch on top of that. What I also wanted to try is make the GIT_DISCOVERY_ACROSS_FILESYSTEM warning go away for crypto home volumes, because that's kind of common and nobody needs git to discover repositories in this case. Only need to come up with an idea how to detect this case. -- Ralf