From: Derrick Stolee Date: Thu, 12 Nov 2020 13:52:24 GMT Subject: Re: [PATCH 1/3] csum-file: add hashwrite_be64() Message-ID: In-Reply-To: <16932ced-8bcd-89bd-b927-cae1bce0365a@web.de> On 11/12/2020 7:20 AM, René Scharfe wrote: > Add a helper function for hashing and writing 64-bit integers in network > byte order. It returns the number of written bytes. This simplifies > callers that keep track of the file offset, even though this number is a > constant. > > Suggested-by: Derrick Stolee > Original-patch-by: Taylor Blau These patches are absolutely correct, and I'm glad to see them show up in a very clear presentation. I had to go look to see why these were not already present, with [1] being the last instance of these showing up on-list. They did not get into the new version after a significant refactor [2]. Thanks, -Stolee [1] https://lore.kernel.org/git/20200904202226.GA21837@nand.local/ [2] https://lore.kernel.org/git/cover.1599664389.git.me@ttaylorr.com/