From: Caleb Thompson Date: Tue, 17 Jun 2014 19:38:58 GMT Subject: [PATCH v6 2/4] commit test: Use write_script Message-ID: In-Reply-To: Use write_script from t/test-lib-functions.sh instead of cat, shebang, and chmod. This aids in readability for creating the script by using the named function and allows us to turn off interpolation in the heredoc of the script body to avoid extra escaping, since $SHELL_PATH is handled for us. Signed-off-by: Caleb Thompson Reviewed-by: Jeremiah Mahler --- t/t7507-commit-verbose.sh | 6 ++---- 1 file changed, 2 insertions(+), 4 deletions(-) diff --git a/t/t7507-commit-verbose.sh b/t/t7507-commit-verbose.sh index 6d778ed..db09107 100755 --- a/t/t7507-commit-verbose.sh +++ b/t/t7507-commit-verbose.sh @@ -3,11 +3,9 @@ test_description='verbose commit template' . ./test-lib.sh -cat >check-for-diff <message <<'EOF' -- 2.0.0