From: Derrick Stolee Date: Wed, 18 Mar 2020 10:57:24 GMT Subject: Re: [PATCH 1/1] submodule--helper.c: Rename 'cb_foreach' to 'foreach_cb' Message-ID: In-Reply-To: <20200318095842.27679-2-shouryashukla.oo@gmail.com> On 3/18/2020 5:58 AM, Shourya Shukla wrote: > In 'submodule--helper.c', the structures and macros for callbacks belonging > to any subcommand are named in the format: 'subcommand_cb' and 'SUBCOMMAND_CB_INIT' > respectively. > > This was an exception for the subcommand 'foreach' of the command > 'submodule'. Rename the aforementioned structures and macros: > 'struct foreach_cb' to 'struct cb_foreach' and 'CB_FOREACH_INIT' > to 'FOREACH_CB_INIT'. I believe your " to " statements are reversed. > Signed-off-by: Shourya Shukla > --- > builtin/submodule--helper.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/builtin/submodule--helper.c b/builtin/submodule--helper.c > index 86a608eec1..1a4b391c88 100644 > --- a/builtin/submodule--helper.c > +++ b/builtin/submodule--helper.c > @@ -444,19 +444,19 @@ static void for_each_listed_submodule(const struct module_list *list, > fn(list->entries[i], cb_data); > } > > -struct cb_foreach { > +struct foreach_cb { > int argc; > const char **argv; > const char *prefix; > int quiet; > int recursive; > }; > -#define CB_FOREACH_INIT { 0 } > +#define FOREACH_CB_INIT { 0 } > > static void runcommand_in_submodule_cb(const struct cache_entry *list_item, > void *cb_data) > { > - struct cb_foreach *info = cb_data; > + struct foreach_cb *info = cb_data; > const char *path = list_item->name; > const struct object_id *ce_oid = &list_item->oid; > > @@ -557,7 +557,7 @@ static void runcommand_in_submodule_cb(const struct cache_entry *list_item, > > static int module_foreach(int argc, const char **argv, const char *prefix) > { > - struct cb_foreach info = CB_FOREACH_INIT; > + struct foreach_cb info = FOREACH_CB_INIT; > struct pathspec pathspec; > struct module_list list = MODULE_LIST_INIT; Based on the description, I was worried this patch would be very large. The fact that the change is so small makes this reasonable in isolation. Thanks, -Stolee