From: Jeff Hostetler Date: Mon, 30 Oct 2017 19:54:14 GMT Subject: Re: What's cooking in git.git (Oct 2017, #07; Mon, 30) Message-ID: In-Reply-To: On 10/30/2017 1:31 PM, Johannes Schindelin wrote: > Hi Junio, > > On Mon, 30 Oct 2017, Junio C Hamano wrote: > >> * jt/partial-clone-lazy-fetch (2017-10-02) 18 commits >> - fetch-pack: restore save_commit_buffer after use >> - unpack-trees: batch fetching of missing blobs >> - clone: configure blobmaxbytes in created repos >> - clone: support excluding large blobs >> - fetch: support excluding large blobs >> - fetch: refactor calculation of remote list >> - fetch-pack: support excluding large blobs >> - pack-objects: support --blob-max-bytes >> - pack-objects: rename want_.* to ignore_.* >> - gc: do not repack promisor packfiles >> - rev-list: support termination at promisor objects >> - sha1_file: support lazily fetching missing objects >> - introduce fetch-object: fetch one promisor object >> - index-pack: refactor writing of .keep files >> - fsck: support promisor objects as CLI argument >> - fsck: support referenced promisor objects >> - fsck: support refs pointing to promisor objects >> - fsck: introduce partialclone extension >> >> A journey for "git clone" and "git fetch" to become "lazier" by >> depending more on its remote repository---this is the beginning of >> it. >> >> Expecting a reroll. >> cf. > > It was my understanding that Jeff's heavy-lifting produced a shorter, > initial patch series with parts of this, that was already reviewed > internally by Jonathan. > > Am I mistaken? > > Ciao, > Dscho > Right. I posted a "part 1" of this last week and am currently rerolling that. I should also have a followup "part 2" patch series shortly. https://public-inbox.org/git/20171024185332.57261-1-git@jeffhostetler.com/ I've been assuming that the jt/partial-clone-lazy-fetch is a placeholder for our next combined patch series. Jeff