From: Phillip Wood Date: Wed, 12 Aug 2020 13:59:48 GMT Subject: Re: [PATCH] rebase -i: Fix possibly wrong onto hash in todo Message-ID: In-Reply-To: <20200811181537.qt7jkoxy7qn3k7mo@haukka.localdomain> Hi Antti On 11/08/2020 19:15, Antti Keränen wrote: > Hi Phillip and Taylor. > > On Tue, Aug 11, 2020 at 04:32:37PM +0100, Phillip Wood wrote: >>> I'm not sure it's worth rearranging these lines. It probably does not matter >>> but we could do >>> >>> + char shortonto[GIT_MAX_HEXSZ + 1]; >>> >>> and then later call find_unique_abbrev_r() instead so we don't have to worry >>> about freeing shortonto. > > I like this. I'll change the code, if the rest of the patch is okay. Thanks great Thanks Phillip > >>> Thanks for taking the trouble to add a test, I think all the lines above >>> could be simplified to >>> >>> GIT_SEQUENCE_EDITOR=cat git rebase -i HEAD~5 branch1 >actual > > Nice! :) There was a test called 'todo count' which I mimicked. This > obviously is much cleaner solution, thanks. > >>> we could lose the final .* > > Ack. > > On Tue, Aug 11, 2020 at 11:36:21AM -0400, Taylor Blau wrote: >> Ack, I noticed this too during my review, but apparently forgot to >> comment on it. I'm puzzled by the first '..*'. If you're searching for >> any non-empty string, how about '.+' instead? > > That's true. Good point. I pretty much copy&pasted the 'todo count' test > so I didn't give this much thought. I'll fix this. >