From: Johannes Sixt Date: Tue, 30 Aug 2016 05:33:23 GMT Subject: Re: [PATCH 05/22] sequencer: allow the sequencer to take custody of malloc()ed data Message-ID: In-Reply-To: <733a899a-470b-79b3-b059-b38313a7057d@gmail.com> Am 29.08.2016 um 23:59 schrieb Jakub Narębski: > W dniu 29.08.2016 o 10:04, Johannes Schindelin pisze: >> -#define REPLAY_OPTS_INIT { -1, -1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, NULL, NULL, NULL, 0, 0, NULL } >> +#define REPLAY_OPTS_INIT { -1, -1, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, NULL, NULL, NULL, 0, 0, NULL, NULL, 0, 0 } > > Nb. it is a pity that we cannot use named initializers for structs, > so called designated inits. It would make this macro more readable. It is actually pointless to add the 0's and NULL's here. This should be sufficient: #define REPLAY_OPTS_INIT { -1, -1 } because initialization with 0 (or NULL) is the default for any omitted members. -- Hannes