From: Michael Haggerty Date: Fri, 16 Jun 2017 06:46:34 GMT Subject: Re: [PATCH 15/28] packed_peel_ref(): new function, extracted from `files_peel_ref()` Message-ID: In-Reply-To: On 06/16/2017 07:42 AM, Stefan Beller wrote: > On Thu, Jun 15, 2017 at 7:47 AM, Michael Haggerty wrote: >> This will later become a method of `packed_ref_store`. > > Also while touching it, maybe rename sha1 to object_hash > (not saying object_id as that would be confusing with the actual > oid struct), maybe? Hmmm, my impression was that most of the `unsigned char *` hashes are still called sha1, and they are renamed to `oid` at the moment that they are converted to `struct object_id *`. I only see two instances of the string "object_hash" in the code: $ git grep object_hash object.c:static void grow_object_hash(void) object.c: grow_object_hash(); Michael