From: Jeremiah Mahler Date: Thu, 12 Jun 2014 07:29:32 GMT Subject: [PATCH v3 0/2] add strbuf_set operations Message-ID: Addition of strbuf_set operations, version 3. Includes suggestions from Eric Sunshine [1]: - Revise log message to better argue why this patch is worthwhile. - Avoid documentation redundancy: "Setting buffer", "Replace buffer". - Remove unnecessary changes which didn't have a significant benefit to avoid unnecessary "code churn". builtin/remote.c was the one file which showed a significant benefit. Others with negligible benefits have been left as is. The possible performance improvements using a strbuf_grow_to() operation as suggested by Michael Haggerty [2] has been left for a later patch. [1]: http://marc.info/?l=git&m=140247618416057&w=2 [2]: http://marc.info/?l=git&m=140248834420244&w=2 Jeremiah Mahler (2): add strbuf_set operations builtin/remote: improve readability via strbuf_set() Documentation/technical/api-strbuf.txt | 18 ++++++++++ builtin/remote.c | 63 +++++++++++++--------------------- strbuf.c | 21 ++++++++++++ strbuf.h | 13 +++++++ 4 files changed, 75 insertions(+), 40 deletions(-) -- 2.0.0