From: Thomas Rast Date: Wed, 27 Mar 2013 20:03:39 GMT Subject: [PATCH v3 0/3] Recursion-free unpack_entry and packed_object_info Message-ID: In-Reply-To: <87620faky3.fsf@linux-k42r.v.cablecom.net> From: Thomas Rast Almost the same as last time. Changed: the rename suggested by Junio > The only little concern I may have is this cmp_* function tells us > "I found it!" by returning true, which is counter-intuitive to the > readers of the caller (not the callee). > > I think it makes sense to compare delta-base-cache entries only for > equality, so eq-delta-base-cache-entry might be a better name for > it, perhaps? and a small reword to patch 3's commit message to make it clearer at which stage we unpack the deltas. Thomas Rast (3): sha1_file: remove recursion in packed_object_info Refactor parts of in_delta_base_cache/cache_or_unpack_entry sha1_file: remove recursion in unpack_entry sha1_file.c | 411 +++++++++++++++++++++++++++++++++++++++--------------------- 1 file changed, 266 insertions(+), 145 deletions(-) -- 1.8.2.344.g1440b22