From: Ævar Arnfjörð Bjarmason Date: Fri, 02 Apr 2021 11:34:32 GMT Subject: [PATCH 0/2] git-send-email: refactor duplicate $? checks into a function Message-ID: In-Reply-To: A tiny series to help along the config-based hooks series[1]. Its patch dealing with git-send-email.perl can now trivially be based on top of this instead of adding another system() wrapper to git-send-email.perl. As alluded to in the TODO comment in 2/2 it's probably best to fix things while we're at it to call validate_patch_error() instead of just emitting the more brief "rejected by sendemail-validate hook". But for now this series is just aiming for bug-for-bug compatibility with the existing code, and to just reduce code duplication. http://lore.kernel.org/git/20210311021037.3001235-1-emilyshaffer@google.com Ævar Arnfjörð Bjarmason (2): git-send-email: replace "map" in void context with "for" git-send-email: refactor duplicate $? checks into a function git-send-email.perl | 49 +++++++++++++++++++++++++++++---------------- 1 file changed, 32 insertions(+), 17 deletions(-) -- 2.31.1.482.g6691c1be520