From: Michael Haggerty Date: Wed, 17 May 2017 15:49:16 GMT Subject: Re: [PATCH 09/23] files-backend: move `lock` member to `files_ref_store` Message-ID: In-Reply-To: <20170517131459.uznay3pmzgxijunm@sigill.intra.peff.net> On 05/17/2017 03:15 PM, Jeff King wrote: > On Wed, May 17, 2017 at 02:05:32PM +0200, Michael Haggerty wrote: > >> @@ -70,6 +61,13 @@ struct files_ref_store { >> >> struct ref_cache *loose; >> struct packed_ref_cache *packed; >> + >> + /* >> + * Iff the packed-refs file associated with this instance is >> + * currently locked for writing, this points at the associated >> + * lock (which is owned by somebody else). >> + */ >> + struct lock_file *packlock; > > I'm glad to see you renamed this from just "lock", though the short > "pack" makes me think of packed objects. I don't know if > "packed_refs_lock" would be too verbose (I see it's just "packed" above, > so maybe "packed_lock"). > > I'll rename it to `packed_refs_lock`. Michael