From: Sverre Rabbelier Date: Wed, 14 Jan 2009 15:55:45 GMT Subject: Re: [PATCH 3/3] implement pattern matching in ce_path_match Message-ID: In-Reply-To: On Wed, Jan 14, 2009 at 16:44, Johannes Schindelin wrote: >> +static int has_special(const char *p) >> +{ >> + int x; >> + >> + while ((x = *p++) != '\0') >> + if (isspecial(x)) >> + return 1; >> + >> + return 0; >> +} > > I would prefer something like this: > > static int has_special(const char *p) > { > while (*p) > if (isspecial(*(p++))) > return 1; > return 0; > } > > but that is probably a matter of taste. FWIW, I think the above is a lot less readable due to the assignment in the while loop's conditional. Whereas in Dscho's version it is intuitively obvious what the termination condition of the while loop is. -- Cheers, Sverre Rabbelier