From: René Scharfe Date: Mon, 12 Dec 2016 19:51:14 GMT Subject: Re: [PATCH 1/3] compat: add qsort_s() Message-ID: In-Reply-To: Am 01.12.2016 um 21:22 schrieb Junio C Hamano: > Junio C Hamano writes: > >> Eh, wait. BSD and Microsoft have paramters reordered in the >> callback comparison function. I suspect that would not fly very >> well. > > Hmm. We could do it like this, which may not be too bad. It's kinda cool to have a bespoke compatibility layer for major platforms, but the more I think about it the less I can answer why we would want that. Safety, reliability and performance can't be good reasons -- if our fallback function lacks in these regards then we have to improve it in any case. Text size could be a valid reason, but the full function only adds a bit more than 2KB to the unstripped git binary. The flip side is we'd build an ifdef maze that's harder to read and a lot more difficult to test. What do we get in return for that additional complexity? > #if APPLE_QSORT_R > struct apple_qsort_adapter { > int (*user_cmp)(const void *, const void *, void *); > void *user_ctx; > } > > static int apple_qsort_adapter_cmp(void *ctx, const void *a, const void *b) > { > struct apple_qsort_adapter *wrapper_ctx = ctx; > return wrapper_ctx->user_cmp(a, b, wrapper_ctx->user_ctx); > } > #endif > > int git_qsort_s(void *b, size_t n, size_t s, > int (*cmp)(const void *, const void *, void *), void *ctx) > { > if (!n) > return 0; > if (!b || !cmp) > return -1; > #if GNU_QSORT_R > qsort_r(b, n, s, cmp, ctx); > #elif APPLE_QSORT_R > { > struct appple_qsort_adapter a = { cmp, ctx }; > qsort_r(b, n, s, &a, appple_qsort_adapter_cmp); > } > #endif Nit: The fallback for non-GNU, non-Apple systems is missing here, but the idea is illustrated clearly enough. > return 0; > } >