From: Johannes Schindelin Date: Thu, 03 Apr 2008 19:58:58 GMT Subject: Re: [PATCH 1/4] "log" and friends: --children option Message-ID: In-Reply-To: <7vlk3v2tg9.fsf@gitster.siamese.dyndns.org> Hi, On Thu, 3 Apr 2008, Junio C Hamano wrote: > @@ -1398,6 +1404,26 @@ int setup_revisions(int argc, const char **argv, struct rev_info *revs, const ch > return left; > } > > +static void add_child(struct rev_info *revs, struct commit *parent, struct commit *child) > +{ > + struct commit_list *l = xcalloc(1, sizeof(*l)); > + > + l->item = child; > + l->next = add_decoration(&revs->children, &parent->object, l); > +} > + > +static void set_children(struct rev_info *revs) I'd call this add_children(). Other than that, nicely done! I did not think it was possible with as few changes. Ciao, Dscho