From: Daniel Barkalow Date: Tue, 04 Mar 2008 03:11:35 GMT Subject: Re: [PATCH 1/3] git-pack-objects: Automatically pack annotated tags if object was packed Message-ID: In-Reply-To: <20080304030631.GN8410@spearce.org> On Mon, 3 Mar 2008, Shawn O. Pearce wrote: > Daniel Barkalow wrote: > > On Mon, 3 Mar 2008, Shawn O. Pearce wrote: > > > > > + if (auto_tags && nr_result) > > > + for_each_ref(add_ref_tag, NULL); > > > > There's for_each_tag_ref() that does the path-based filter internally, in > > a possibly more efficient way, and avoids open-coding the test for whether > > this is a tag sort of ref. > > Yea, I know about that call, but I didn't use it because I was > trying to use peel_ref() for its optimized peeled caching in > a packed-refs file. Ah, okay. I hadn't noticed that it didn't pass on the full name. Using for_each_ref() is better, then, I think. -Daniel *This .sig left intentionally blank*