From: Nicolas Pitre Date: Tue, 18 Aug 2009 18:16:35 GMT Subject: Re: [PATCH] block-sha1: Windows declares ntohl() in winsock2.h Message-ID: In-Reply-To: <7vpratdpc8.fsf@alter.siamese.dyndns.org> On Tue, 18 Aug 2009, Junio C Hamano wrote: > To reduce confusion, you may want to rename compat/bswap.h to something > like compat/ntohl-htonl-fix.h ;-) Bah. If you wish, you can edit the patch directly for this, unless you really prefer me to repost. Maybe we might want to add a 8-byte versions of those as well eventually, which is why I chose a more generic name. Nicolas