From: Matthew DeVore Date: Wed, 17 Oct 2018 13:24:05 GMT Subject: Re: [RFC] revision: Add --sticky-default option Message-ID: In-Reply-To: <20181017091215.GA2052@sigill.intra.peff.net> On Wed, 17 Oct 2018, Jeff King wrote: > > Yuck, t4202 is a mix of older and newer styles. I'm OK with this as-is > because you've matched the surrounding code, but these days I'd probably > write: > > test_expect_success '--sticky-default ^' ' > { > echo sixth > echo fifth > } >expect && > git log --format=%s --sticky-default ^HEAD~2 >actual && > test_cmp expect actual > ' > How about test_write_lines? That is a little more readable to me than the echos in a subshell. A patch was recently queued with a usage of that function: https://public-inbox.org/git/CAMfpvhK4a15gd-PT3W+4YJmpe6c7HyhJE5N_UqOzu8gsYYej4A@mail.gmail.com/T/#m9b5ade1551722938ac97b75af58fec195f246c01 - Matt