From: Johannes Schindelin Date: Thu, 26 Jan 2017 14:45:28 GMT Subject: Re: [PATCH] connect: handle putty/plink also in GIT_SSH_COMMAND Message-ID: In-Reply-To: Hi Junio, On Wed, 25 Jan 2017, Junio C Hamano wrote: > Subject: [PATCH] connect: rename tortoiseplink and putty variables > > One of these two may have originally been named after "what exact > SSH implementation do we have" so that we can tweak the command line > options, but these days "putty=1" no longer means "We are using the > plink SSH implementation that comes with PuTTY". It is set when we > guess that either PuTTY plink or Tortoiseplink is in use. > > Rename them after what effect is desired. The current "putty" > option is about using "-P " when OpenSSH would use "-p ", > so rename it to port_option whose value is either 'p' or 'P". The > other one is about passing an extra command line option "-batch", > so rename it needs_batch. > > Signed-off-by: Junio C Hamano Apart from an overly-long line, this patch looks good. It made my life a little harder, as I had to rebase Segev's ssh.variant (why this should be a core.* variable is not clear to me) patch and it caused conflicts. I resolved those conflicts and made both patches part of this patch series. Will contribute v2 as soon as the test suite passes, Johannes