From: Johannes Schindelin Date: Wed, 17 Aug 2016 09:13:43 GMT Subject: Re: git cherry-pick conflict error message is deceptive when cherry-picking multiple commits Message-ID: In-Reply-To: <968827697.1226723.1471337060482.JavaMail.zimbra@ensimag.grenoble-inp.fr> Hi, On Tue, 16 Aug 2016, Remi Galan Alfonso wrote: > Stephen Morton writes: > > + if (multiple_commits) > > + advise(_("after resolving the conflicts, > > mark the corrected paths with 'git add ' or 'git rm '\n" > > + "then continue with 'git %s > > --continue'\n" > > + "or cancel with 'git %s > > --abort'" ), action_name(opts), action_name(opts)); > > + else > > + advise(_("after resolving the > > conflicts, mark the corrected paths\n" > > + "with 'git add ' or 'git > > rm '\n" > > + "and commit the result with > > 'git commit'")); > > In both cases (multiple_commits or not), the beginning of the advise > is nearly the same, with only a '\n' in the middle being the > difference: > > multiple_commits: > "after resolving the conflicts, mark the corrected paths with 'git > add ' or 'git rm '\n" > > !multiple_commits: > "after resolving the conflicts, mark the corrected paths\n with 'git > add ' or 'git rm '\n" > ~~~~~~~^ > > In 'multiple_commits' case the advise is more than 80 characters long, > did you forget the '\n' in that case? > > If you end up using the same beginning of advice, maybe it's possible > to give it before the 'if(multiple_commits)' and avoid duplication of > the lines. I concur with this, and also with Christian's advice to append the parameter consistently as last one, and also with renaming it to "last_commit". Ciao, Johannes