From: Johannes Schindelin Date: Tue, 14 Jun 2016 13:44:24 GMT Subject: Re: [PATCH] Refactor recv_sideband() Message-ID: In-Reply-To: Hi, On Mon, 13 Jun 2016, Nicolas Pitre wrote: > On Mon, 13 Jun 2016, Lukas Fleischer wrote: > > > Improve the readability of recv_sideband() significantly by replacing > > fragile buffer manipulations with more sophisticated format strings. > > Also, reorganize the overall control flow, remove some superfluous > > variables and replace a custom implementation of strpbrk() with a call > > to the standard C library function. > > > > Signed-off-by: Lukas Fleischer > > The previous code was a total abomination, even if I happen to know who > wrote it. Let's give Junio a break, okay? He does a kick-ass job at maintaining Git. What we see here is simply good software development, nothing more, nothing less: an initial, working code being improved. No need to make the original author feel bad... :-) Ciao, Dscho